본문 바로가기

Php

쓰기

php-zip 설치시 error

haru 2018.03.29 14:33 조회 수 : 96

# yum install php-zip

Loaded plugins: fastestmirror

Loading mirror speeds from cached hostfile

 * base: ftp.neowiz.com

 * epel: ftp.riken.jp

 * extras: mirror.kakao.com

 * remi-php71: mirrors.mediatemple.net

 * remi-safe: mirrors.mediatemple.net

 * updates: mirror.kakao.com

 * webtatic: sp.repo.webtatic.com

Resolving Dependencies

--> Running transaction check

---> Package php72w-common.x86_64 0:7.2.2-1.w7 will be installed

--> Processing Conflict: php72w-common-7.2.2-1.w7.x86_64 conflicts php-common < 7.2

--> Finished Dependency Resolution

Error: php72w-common conflicts with php-common-7.1.16-1.el7.remi.x86_64

 You could try using --skip-broken to work around the problem

 You could try running: rpm -Va --nofiles --nodigest

 
위와같이 나오는경우 아래와같이 진행하면 정상설치가 가능하다.
 
yum install libzip*
진행한뒤 다시
yum install php-zip 을 진행하면 정상설치된다.
 
# php -m
[PHP Modules]
bz2
calendar
Core
ctype
curl
date
dom
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
json
libxml
mbstring
mysqli
mysqlnd
odbc
openssl
pcntl
pcre
PDO
pdo_dblib
pdo_mysql
PDO_ODBC
pdo_sqlite
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlwriter
xsl
zip
zlib
 
[Zend Modules]